Increased latency on /search endpoints

Incident Report for Peach

Resolved

There are no longer any across the board latency issues for the `/search` endpoint. However, there are periodic slowdowns when doing a "full text search" with certain inputs.

When using the Peach CRM frontend a "full text search" means using the search box without specifying a search prefix. When using the Peach API this means using the param `_hasTheWords=`.

If you encounter a slow down when using the full text search, a workaround is to specify the appropriate search prefix. e.g., if you are searching for a borrower external ID like `my-external-id` in the search box type `id:my-external-id`. If you are using the API use `.../search?_hasTheWords=my-external-id`
Posted Oct 30, 2025 - 22:39 UTC

Monitoring

We've released a fix and are monitoring to see if it resolves the issue.
Posted Oct 28, 2025 - 22:56 UTC

Update

The impact of the increased latency is less widespread than we originally presumed. Only certain classes of input for the previously mentioned parameters are causing the slowdown.

We have a fix we believe will address the issue and will roll it out shortly.
Posted Oct 27, 2025 - 23:23 UTC

Identified

The Borrower and Interaction search endpoints have increased latency when searching with "full text" queries. These include `_hasTheWords` and `_notTheWords` parameters. We've identified the issue and are working on a fix.
Posted Oct 27, 2025 - 19:43 UTC
This incident affected: API and Agent Portal.