Borrower campaigns failing to send physical mail

Incident Report for Peach

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 01:04 UTC

Update

The issue appears to be resolved but we will continue to monitor.
Posted Oct 08, 2025 - 01:02 UTC

Monitoring

We deployed a fix and we're are monitoring to see if this resolve the issue.
Posted Oct 08, 2025 - 00:08 UTC

Identified

We've identified the issue and are working on a fix. We've also confirmed that issue only occurs in the physical mail system when its utilized by the Borrower Campaigns system.
Posted Oct 07, 2025 - 22:05 UTC

Update

We're continuing to investigate, although it appears this outage affects just a single customer.
Posted Oct 07, 2025 - 20:46 UTC

Investigating

Borrower campaigns are currently failing to send communications when a campaign is set to send physical mail (channel=mail).
Posted Oct 07, 2025 - 19:50 UTC
This incident affected: Communications (Physical Mail, Campaigns).