Issue with failed transactions and canceled purchases

Incident Report for Peach

Resolved

Replays are finished and the failed transactions and canceled purchases have been applied correctly.
Posted Aug 05, 2026 - 22:59 UTC

Update

Our fix is live and we're working on verifying the fix and beginning remediation.
Posted Aug 05, 2026 - 20:50 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 05, 2026 - 20:04 UTC

Identified

Replays were unable to complete overnight after a change went live to production. This may cause failed transactions and canceled purchases to not be reflected in loan balances. We have fixed the issue and are working on getting it out to all environments and replaying the affected loans.
Posted Aug 05, 2026 - 20:03 UTC
This incident affected: Peach Adaptive Core, API, and Payment Processing.