Settlements not funded since 6/10

Incident Report for Peach

Resolved

We have verified that reconciliation ACH files were created successfully.
Posted Jun 12, 2026 - 19:35 UTC

Monitoring

We observed reconciliation ACH files generated successfully. We will continue to monitor the automated process.
Posted Jun 12, 2026 - 19:21 UTC

Identified

We have identified an issue with a background process and manually reran it.
Posted Jun 12, 2026 - 18:54 UTC

Investigating

We are investigating settlements not being funded since 6/10.
Posted Jun 12, 2026 - 18:15 UTC
This incident affected: Payment Processing.