Increased latency on certain sync=true endpoints

Incident Report for Peach

Resolved

The elevated latency has come back down.
Posted Jun 11, 2026 - 00:39 UTC

Identified

We have identified the cause of the increased latency.
Posted Jun 11, 2026 - 00:10 UTC

Update

We are still investigating.
Posted Jun 10, 2026 - 23:37 UTC

Investigating

We are currently investigating an increase in latency for some sync=true endpoints.
Posted Jun 10, 2026 - 22:26 UTC
This incident affected: API.