Elevated error rates

Incident Report for Peach

Resolved

Our vendors have set their incidents to resolved and we are awaiting more details from their post mortems.
Posted Jun 13, 2025 - 15:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 21:03 UTC

Update

we are seeing signs of recovery from our internal monitoring and we have received confirmation of a fix being deployed from our vendor. They have said the fix is expected to complete within an hour
Posted Jun 12, 2025 - 21:03 UTC

Update

Our cloud vendor is continuing to experience a major outage. Our on-call team continues to monitor our services and asking for an ETA from our vendor.
Posted Jun 12, 2025 - 20:28 UTC

Update

Our vendor continues to be experiencing an outage, and unfortunately does not have an ETA for resolution.
Posted Jun 12, 2025 - 20:18 UTC

Update

Our cloud vendor is continuing to experience a major outage. Our on-call team is monitoring the situation and we will continue to post here as the issue continues, and as soon as we've experienced service restoration.
Posted Jun 12, 2025 - 19:18 UTC

Identified

We've identified that the issue is caused by an outage with our cloud vendor.
Posted Jun 12, 2025 - 18:26 UTC

Investigating

We are aware of an increase in error rates being returned by the Peach API, and are investigating the root cause.
Posted Jun 12, 2025 - 18:20 UTC
This incident affected: API.