Some PDFs failing to render

Incident Report for Peach

Resolved

All PDFs which failed to generate while Peach internal processes were running have been backfilled.
Posted Aug 29, 2026 - 23:52 UTC

Update

We are beginning to backfill missing PDFs.

This backfill will only fix missing PDFs which failed to render during Peach's internal processes. Any user's public API requests which previously errored during this incident will need to be re-run.
Posted Aug 29, 2026 - 16:52 UTC

Monitoring

A fix has been rolled out and PDFs should render correctly now.

We are working to backfill PDFs that failed to render during the failure window. (e.g., statements)
Posted Aug 29, 2026 - 16:33 UTC

Identified

We've identified the issue preventing PDFs from rendering and are working on a fix.
Posted Aug 29, 2026 - 15:55 UTC

Investigating

We are investigating reports of PDFs failing to render.
Posted Aug 29, 2026 - 15:45 UTC
This incident affected: API.