Increased error rates on frontends due to Cloudflare outage

Incident Report for Peach

Resolved

Peach's frontend portals are functioning normally now.
Posted Nov 18, 2025 - 18:34 UTC

Monitoring

Cloudflare has announced that the service disruption is resolved, and our tests indicate that Peach's frontend portals are operating normally.

We will continue to monitor.
Posted Nov 18, 2025 - 17:48 UTC

Identified

Some Peach frontends (Borrower Portal, Customer Portal and Admin Portal) are experiencing increased error rates due to an outage in a 3rd party provider—Cloudflare. See https://www.cloudflarestatus.com/.

We are monitoring the situation and will attempt to mitigate the impact on Peach services.
Posted Nov 18, 2025 - 15:52 UTC
This incident affected: Agent Portal and Borrower Portal.