Increased latency and timeouts

Incident Report for Peach

Resolved

We identified the problem change and will be reverting it so we can continue with production deploys.
Posted Jun 26, 2026 - 17:32 UTC

Update

We are continuing to investigate this issue.
Posted Jun 26, 2026 - 17:23 UTC

Investigating

Update: the message below covered the bulk of the impact observed, but failed to acknowledge that latency and some errors started to begin happening around 9:30am PT.

Original message:
We observed an increase in client timeouts and error rate from 9:53am to 9:54am PT today. Latency and error rate are back to normal levels now. A production deploy caused an increase in memory that caused the impact. We rolled back the deploy and are investigating the root cause.
Posted Jun 26, 2026 - 17:20 UTC
This incident affected: API.