Elevated API Errors

Incident Report for Peach

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 18:37 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 09, 2025 - 18:45 UTC

Monitoring

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Jun 06, 2025 - 22:20 UTC
This incident affected: API.