Snapshots and loan tapes delayed by cloud vendor provisioning issue

Incident Report for Peach

Resolved

Our mitigating efforts yesterday worked and the issue did not reoccur overnight.
Posted Jul 03, 2026 - 17:59 UTC

Update

Data pipelines are complete. We will be monitoring the situation overnight but we do not expect the issue to happen again.
Posted Jul 03, 2026 - 01:46 UTC

Update

The final data pipelines which ingested from loan tapes should be caught up shortly after the scheduled ingestion runs again at approximate 5:30pm PT—will update after completion.
Posted Jul 03, 2026 - 00:24 UTC

Monitoring

All loan tapes have completed generating.

Some customers have additional data pipelines that ingest loan tapes. We are validating now if those are regenerating correctly.
Posted Jul 02, 2026 - 23:53 UTC

Update

Snapshots are done and loan tapes are completing now. We will update again when all tapes are complete.
Posted Jul 02, 2026 - 23:11 UTC

Update

Batch processes have been continuing but at a slower than normal rate, due to a lower amount of compute being provisioned from our cloud vendor. We now have our regular amount of compute being provisioned, so we expect batch process throughput to increase momentarily. We are increasing resources to catch up and have things complete as soon as possible.
Posted Jul 02, 2026 - 19:10 UTC

Identified

An issue with our cloud vendor has led to some of our overnight batch jobs to be delayed. This includes snapshots and loan tapes. We are working to get these jobs completed as soon as possible.
Posted Jul 02, 2026 - 17:32 UTC
This incident affected: Data (Loan and Payment Tapes).