Increased Latency On Events Endpoint

Incident Report for Peach

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 18:30 UTC

Monitoring

We observed increased latency on the Events endpoint from approximately 8:00 AM PT to 11:00 AM PT on July 9. The issue is now over, and endpoint performance has returned to normal levels.

We are continuing to monitor the system to ensure latency remains stable.
Posted Jul 09, 2026 - 18:17 UTC