Elevated API latency

Incident Report for Peach

Resolved

Global Peach API latency is back to normal levels.
Posted Jun 04, 2026 - 22:48 UTC

Update

API latency has normalized and now asynchronous jobs are catching up. Endpoints called with sync=true will remain impacted until async job queues catch back up.
Posted Jun 04, 2026 - 22:22 UTC

Monitoring

The rollback is complete and we're observing API reduction back to normal. We're now monitoring to see that API latency continues to flatten out and also that our worker jobs catch up.
Posted Jun 04, 2026 - 22:04 UTC

Identified

We've identified the issue and are rolling back the production deploy that introduced it. We expect API latency to return to normal within 15 to 20 minutes.
Posted Jun 04, 2026 - 21:56 UTC

Investigating

We're currently investigating elevated API latency. We will update within the next 30min as we know more.
Posted Jun 04, 2026 - 21:42 UTC
This incident affected: API.