Elevated error rate on get balances endpoint

Incident Report for Peach

Resolved

Continued internal monitoring and testing confirms that the errors have been resolved. All services are back to full operational capacity. We apologize for any inconvenience this may have caused you or your customers. We will conduct a full post-mortem to understand the root cause and implement preventative measures to avoid recurrence.
Posted Sep 06, 2025 - 13:57 UTC

Monitoring

We have reverted to the previous version of the Peach service. Internal testing indicates that this has restored full operations for the get balances endpoint.
Posted Sep 06, 2025 - 13:39 UTC

Investigating

We are currently investigating elevated errors rates on the get balances endpoint. Users may experience errors when trying to get the balances of recently created loans. Our engineers are actively working to identify the root cause and restore full functionality as quickly as possible. We will provide an update in an hour or as more information becomes available.
Posted Sep 06, 2025 - 12:48 UTC
This incident affected: API.