We are continuing to monitor for any further issues.
Posted Aug 27, 2026 - 21:39 UTC
Monitoring
The automated replica system is caught up and all customers should have received their replication artifacts now. We will continue monitoring to ensure the system is stable.
Posted Aug 27, 2026 - 21:39 UTC
Update
The backlog has been cleared and replication artifacts should be regenerated and sent soon within the next hour.
Posted Aug 27, 2026 - 20:33 UTC
Update
The replication process has almost caught up. We estimate backlog will be done processing in one to two hours.
Posted Aug 27, 2026 - 20:04 UTC
Update
Replication artifacts—mostly parquet files—for the effected customers have been manually generated, but out of an abundance of caution those artifacts won't be fed into the automated delivery pipeline. If our customer support team does not contact you to arrange manual delivery of the replication artifacts and you need them, reach out to the support team.
We expect the automated replica pipeline backlog to be resolved some ~24-30 hours after this message posts.
There will be no further updates until 10am PT Thursday Aug 25—unless there's a substantial change in status.
Posted Aug 27, 2026 - 01:33 UTC
Update
We are continuing to investigate solutions to resolve the backlogged replication stream. In the meantime, we will start manually generating replication artifacts and delivering them manually to customers who are effected by this delay.
Posted Aug 26, 2026 - 20:50 UTC
Update
We have identified a process which is bottlenecking the data outbox / replica v3 replication stream. We are working on a fix to speed up or cancel this process to return replication to normal.
Posted Aug 26, 2026 - 18:46 UTC
Identified
We've identified an issue with delivery of the daily loan snapshots dataset (via data outbox / replica v3) being delayed. Snapshot data for August 24 and August 25 has not yet been delivered. We are working on a fix now.
(Loan and account data itself is complete and correct in Peach's systems — this is a delivery delay affecting one dataset, not a loss of data.)
Posted Aug 26, 2026 - 17:40 UTC
Investigating
We are investigating reports of snapshots tables failing to sync via data outbox (AKA replica v3).