Increased errors on API endpoints

Incident Report for Peach

Resolved

Continued internal monitoring and testing confirms that the errors have been resolved. All services are back to full operational capacity. We apologize for any inconvenience this may have caused you or your customers.
Posted Nov 26, 2025 - 22:57 UTC

Monitoring

The team has identified the issue and implemented a fix. We are seeing error rates subside but will continue to monitor closely.
Posted Nov 26, 2025 - 21:41 UTC

Investigating

We are currently investigating elevated errors rates on some endpoints including get balances. Our engineers are actively working to identify the root cause and restore full functionality as quickly as possible.
Posted Nov 26, 2025 - 21:32 UTC
This incident affected: API.