Delay in some transfer settlements

Incident Report for Peach

Resolved

The delayed transfer settlements are properly processing as of noon pacific time today. The settlements should complete as normal now.
Posted Jun 29, 2026 - 19:43 UTC

Update

A small number of transfer settlements continue to remain unprocessed due to unexpectedly high load with a 3rd party infrastructure provider. It’s unlikely these can be remediated before EOD Friday June 26, and as such, they’ll need to remain unprocessed until the next weekday—Monday June 29. We’ll post an update then as to their processing status.
Posted Jun 26, 2026 - 22:12 UTC

Identified

We have identified an issue that is delaying transfer settlements for funds derived from card payments. We are working to resolve the issue.
Posted Jun 25, 2026 - 20:43 UTC

Investigating

We are investigating an issue that may be causing a delay in processing 1-2% of transfer settlements.
Posted Jun 25, 2026 - 20:21 UTC