Delays in sending loan tapes
Incident Report for Peach
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 20:45 UTC
Monitoring
A fix has been implemented. Some might get the tape twice, but it will be the same tape.
Posted Sep 21, 2022 - 18:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 21, 2022 - 17:15 UTC
Investigating
We are experiencing delays in sending loan tapes
Posted Sep 21, 2022 - 16:34 UTC
This incident affected: Data (Loan Tapes).